Apple が発表した新言語 Swift が話題になってますね。 ほとんどの人は Xcode で試すのでしょうけど、あんな不便なIDEを使いたくない Emacs 病の人がいるかと思います。

すでに swift-mode なるものが package.el からインストールできるようになってるのでさっそくインストールしましょう。 以下を Emacs で実行すればOK。

1
M-x package-install swift-mode

GitHub - swift-mode